[030122/030123]

市販16MB拡張メモリを、修理しました  *追記あり.

"お年玉換装サービス"が縁で、ある方から「壊れている市販16MB拡張メモリ」を譲って頂きました。
市販されていた16MB拡張メモリは、写真などでは何度となくお目に掛かっていますが、実物を見るのは(生まれて)初めて!w(^o^)w
*追記 [0123]
きしもとさんから、"初期の頃に、もう1種市販されていたよ!"という情報を頂きました。(えーっ、知らなんだ!このタイプだけだと思ってた...) 感謝![(_~_)]

物珍しさ(当主だけ)もあって、修理してみる事にしました。結果は、(危うい状態で)修復できています。
(経時変化で、その内不具合が発生するかも)

状況の確認.
実際に装着した状態などを、色々研究(っても、ただ眺めていただけです)。

で、おもむろに電源を投入すると、虚しく「4MB表示」が返って来ます。コネクタがやや甘くなっていますが、接触不良でもなさそうです。何度も、差し込んだり外したりしてみましたが、やはりダメ。

恐らくパターンの断線でしょうから、テスタで導通チェックしたり、半田を追加して様子を見てもよかったのですが、一度メモリ・チップを全部剥がして、基板の状態をみる事にしました。(後学のため?)

メモリ・モジュールの購入.
チップが死んでいる事はまず無いだろうと思いましたが、どうせ剥がすのだから新しいチップに積み替えてやろうと、3.3VのSDIMを買って来ました。

どのようなチップがいいのか、正確に分かっていたわけではないのですが、兎に角3.3V品で、8ビット幅のものであればいいだろうと、「XX17800」のマークを探して(中古店の)店頭で選びまくりました。(因みに、元のチップは、日立製51W17800
幸い、三菱製M5M4V17800が載っているメモリ・モジュールが見付かったので、これを購入して来ました。(\1,480+税)

メモリ板の繕い.
コネクタに近いチップもあるので、ちょっと不安でしたが、何とかホット・ブロアで全チップを剥がしました。
その直後の状態では、基板は何事も無いかのように見えましたが、半田吸取線で半田を吸い取り始めたら、ランドが2つ程ポロッと剥がれ落ちて来ました。
ランドの剥がれ掛けに加えて、リード線もその付け根で切れていたようです。(こんなのは、目視などでは到底分からないですねぇ)

ここで、徹底的に他のランドもこそげるようにして確かめておけばよかったのですが...(ちょと抜かった!)
配線パターンの写真を撮って補修箇所を確認後、モジュールから剥がした新しいチップを、直ぐに載せてしまいました。(急いては、事を仕損じる?)

全8チップを半田付けし終えて、PC110に載せてみると...
始めは、20MBの表示が出ていましたが、Win95がエラーだらけで立ち上がりません。
何回か抜き差しする内に、遂に初期表示が4MBになってしまいました!(とほほ...)

最終結果.
そこで、再度、全端子に丁寧に追加の半田盛りをしてみたら、やっと!20MB表示に戻りました。そして、Win95も正常に立ち上がったってわけ。
これは、恐らくリード線の切れ掛けていた箇所が、追加半田で辛うじて繋がったのでしょう。大変、危なっかしい事です!(何時不具合が出て来るかと、冷や冷やしていなければなりません)
こうした箇所は、本来なら、きちんと配線で補うべき所です。(でも、もう場所が分からない)

折角、チップまで外してみたのに、"パターン剥がれが更に増えるのを嫌って、急いで蓋をしてしまった"ことで、反って瑕疵を残してしまったようです。

[表紙頁]へ  関連記事の目次へ  [一言板]へ